Archiv des LibreOffice- und OpenOffice.org-Wiki

[ÜberSicht] [TitelIndex] [WortIndex] [SeiteFinden

Mit Namen kann man sich die Arbeit in Calc sehr erleichtern und erhält übersichtlichere Formeln.

1. Ein Name für eine Zelle, eine Konstante oder einen Zellbereich

1.1. Eine Zelle benennen

Angenommen, in einem TabellenDokument wird an verschiedensten Stellen und in unterschiedlichen Tabellen mit einem Umrechnungscode für Währungen gerechnet, der zentral in einer Zelle hinterlegt ist. Wenn man nun dieser Zelle den Namen DevisenKurs vergibt, kann man diesen Namen in den Formeln aller Tabellen verwenden, ohne sich um die genaue Zelladresse kümmern zu müssen.

Menü: Einfügen → Namen → festlegen

(!) Wenn man Namen in der Formel-Eingabezeile verwendet, muss man u.U. die Return-Taste zum Abschließen der Formel 2x drücken. Bei der Eingabe mit dem FunktionsAutopiloten ist das jedoch nicht der Fall.

NamenEinfuegenZelle.png

Eine Formel wird dann so geschrieben:

=A1*DevisenKurs

wobei der Name der Zelle nicht in Anführungszeichen gesetzt werden darf.

1.2. Eine Konstante definieren

Wenn im obigen Beispiel der Währungskurs nicht in einer Zelle hinterlegt werden soll, kann der Name DevisenKurs auch direkt einen Wert aufnehmen statt einer Zelladresse:

Menü: Einfügen → Namen → festlegen

Um den Wert zu änderen wird das gleiche Fenster über Einfügen → Namen → festlegen aufgerufen, der Name markiert, der Wert überschrieben und die Schaltfläche Ändern anklickt.

NamenEinfuegenWert.png

Die Verwendung in einer Formel ist gleich wie bei einer benannten Zelle:

=A1*DevisenKurs

1.3. Einen Zellbereich benennen

Oft wird in Funktionen nicht eine Zelladresse benötigt, sondern ein ganzer Zellbereich, der üblicherweise so geschrieben wird: Tabelle1.A1:H23. Meist muss der Bezug jedoch ohnehin absolut sein und man muss den Bereich also so schreiben $Tabelle1.$A$1:$H$23, damit beim Kopieren die Adressen nicht angepasst werden.

Menü: Einfügen → Namen → festlegen

Um den Zellbereich später zu änderen wird das gleiche Fenster über Einfügen → Namen → festlegen aufgerufen, der Name markiert, der Zellbereich angepasst und die Schaltfläche Ändern anklickt.

NamenEinfuegenBereich.png

Die Verwendung in einer Formel ist gleich wie bei einer benannten Zelle:

=NETTOARBEITSTAGE(A2;B2;Feiertage)

Ein weiterer Vorteil: Angenommen, der Bereich muss später erweitert werden, so kann einfach die Namens-Zuordnung geändert werden, ohne dass Formeln angepasst werden müssen

1.4. Ein Name für eine Zelle in einer anderen Datei

NamenEinfuegenFormel.png

Diese Variante eröffnet z.B. die folgende Möglichkeit:

2. Namenfeld

Ganz links in der Eingabezeile liegt das Kombinationsfeld „Namenfeld“ (bis OOo1.1.* „Tabellenbereich“). Alle über Einfügen → Namen festgelegten Bezeichnungen für Zellen und Bereiche werden in der Auswahlliste aufgeführt. Durch Klick auf den Namen wird der zugehörige Bereich ausgewählt und die linke obere Zelle des Bereichs ist aktiviert.

dropdownkommentiert.png

Ab OOo2.0 kann man auch umgekehrt eine Zelle oder einen Zellbereich markieren, den im Namenfeld angezeigten Bezug löschen und eine eigene Bezeichnung eintragen. Sobald man die Eingabe mit der Return-Taste abschließt, wird ein Name mit absolutem Bezug auf die markierten Zellen angelegt, so als habe man Einfügen → Namen benutzt.

3. Namen im Navigator

Namen von Zellen und Zellbereichen werden im Navigator unter dem Titel Bereichsnamen angezeigt. Per Doppelklick auf einen Namen wird der zugehörige Zellbereich direkt ausgewählt.

Per Drag&Drop kann so ein Bereich aus dem Navigator als Kopie, Link oder Verknüpfung in die aktuelle Tabelle gezogen werden.

4. Auf benannte Zellen (Zellbereiche) einer externen Datei zugreifen

Die Funktion DDE() erlaubt die Verwendung von Zell- bzw. Zellbereichsnamen. Im folgenden Beispiel wird die Funktion SVERWEIS() verwendet, um Daten aus einem Bereich einer anderen Datei zuzuordnen.

Wenn man die übliche Schreibweise für Tabellennamen und Zelladressen verwendet, würde eine Funktion z.B. so aussehen:

=SVERWEIS(A1;'file:///home/ich/test.ods'#$Tabelle1.$A$1:$B$23;2)

Hier ist es nicht möglich, die Bereichsadresse $Tabelle1.$A$1:$B$23 durch einen via Einfügen → Namen erfassten Bereichsnamen zu ersetzen.

Hingegen kann man mit DDE folgende Schreibweise anwenden:

=SVERWEIS(A1;DDE("soffice";"file:///home/ich/test.ods";"NameBereich");2)

Ein erfreulicher Nebeneffekt dabei ist, dass bei der zweiten Variante die Dateigröße erheblich geringer ist als bei der ersten Variante. Andererseits macht das Öffnen ohne Aktualisierung hier keinen Sinn, während bei der ersten Variante in dem Fall die letzte gespeicherte Version angezeigt wird.

5. Siehe auch


KategorieCalc


LizenzBedingungen | AnbieterKennzeichnung | DatenschutzErklärung | Stand: 2013-04-28