Archiv des LibreOffice- und OpenOffice.org-Wiki

[ÜberSicht] [TitelIndex] [WortIndex] [SeiteFinden

Aufgabenstellung: Aus einer Tabelle soll der Inhalt einer Zelle wiedergegeben werden, deren Position durch einen Spaltentitel und eine Zeilenbezeichnung definiert ist.

Dazu werden zwei Funktionen verwendet:

SVERWEIS sucht in der ersten Spalte einer Matrix einen Wert und gibt beim Auffinden dieses Wertes den Inhalt der x-ten Spalte derjenigen Zeile zurück, in welcher der Suchwert gefunden wurde. Welche Spalte gewählt werden muss, ermittelt die Funktion VERGLEICH().

VERGLEICH liefert die Position innerhalb einer Zeile oder Spalte, in der sich ein Suchwert befindet.

1. Beispiel: Entfernungstabelle

A

B

C

D

E

F

1

Start:

Barcelona

In Zelle B1 wird der Start-Ort eingegeben, in Zelle B2 der Ziel-Ort und in Zelle B3 soll die Distanz ermittelt werden.

2

Ziel:

Madrid

3

Distanz:

642 km

4

Madrid

Barcelona

Bilbao

Valencia

Alicante

5

Madrid

0

642

391

358

424

6

Barcelona

642

0

598

371

548

7

Bilbao

391

598

0

672

789

8

Valencia

358

371

672

0

177

9

Alicante

424

548

789

177

0

Die Funktion in Zelle B3 heisst: =SVERWEIS(B1;A5:F9;VERGLEICH(B2;A4:F4;0);0)

2. Beispiel: Preistabelle

A

B

C

D

E

F

1

Artikel:

Rock

In Zelle B1 wird der Artikel eingegeben, in Zelle B2 die Grösse und in Zelle B3 soll der Preis ermittelt werden.

2

Grösse:

42

3

Preis:

35

4

Grösse 36

Grösse 38

Grösse 40

Grösse 42

Grösse 44

5

Bluse

10

12

14

16

18

6

Rock

20

25

30

35

40

7

Hose

32

37

42

47

52

8

Pullover

55

58

61

64

67

9

Mantel

175

180

185

190

195

Die Funktion in Zelle B3 heisst: =SVERWEIS(B1;A5:F9;VERGLEICH(B2;A4:F4;0);0)

3. Tipps

4. Beispieldatei

5. Siehe auch


KategorieCalc


LizenzBedingungen | AnbieterKennzeichnung | DatenschutzErklärung | Stand: 2013-04-28