Archiv des LibreOffice- und OpenOffice.org-Wiki

[ÜberSicht] [TitelIndex] [WortIndex] [SeiteFinden

Editieren

(./) OOo 2.0

{i} Die nachstehenden Beispiele wurden mit OpenOffice.org, Version 2.0 erstellt. Da sich in dieser Version im Bereich Matrixformeln einiges geändert hat, ist es gut möglich, daß nicht alle Beispiele in früheren Versionen nachvollzogen werden können.
Zur Erinnerung: Matrix-Formeln immer mit Shift+Ctrl+Return abschließen.


1. Diejenigen Zellen eines Bereichs addieren, die bestimmte Bedingungen erfüllen

Bei den Rechenbeispielen für Zellbereiche ist die Funktionsweise von Matrix-Formeln klar ersichtlich: es werden mehrere Zellbereiche miteinander verrechnet und das Ergebnis ist wieder ein ganzer Zellbereich.

Bei den folgenden Anwendungen ist das nicht von vornherein sichtbar, dennoch ist die Funktionsweise die gleiche.

Es sollen nur Werte summiert werden, die

größer als 2 sind
UND
kleiner als 6 sind
UND
bei denen in Spalte B II steht

A

B

1

 1 

 I

2

 2 

 II

3

 3 

 II

4

 4 

 I

5

 5 

 II

6

 6 

 II

7

8

{=SUMME((A1:A6>2)*(A1:A6<6)*(B1:B6="II")*(A1:A6))}

Was intern geschieht:
Pro Bedingung wird eine Spalte mit einer Wahrheitsprüfung angelegt, die als Ergebnis 1 (Richtig) oder 0 (Falsch) ergibt. All diese Wahrheitswerte werden horizontal multipliziert, d.h., es kann in einer Zeile nur dann "1" herauskommen, wenn alle Wahrheitswerte dieser Zeile "1" ergeben haben. Dieses Wahrheitsergebnis wird nun noch multipliziert mit der zu summierenden Spalte. Dabei kommt überall 0 heraus, wo das Wahrheitsergebnis nicht "1" ist. Überall da, wo das Wahrheitsergebnis "1" ist, bleibt der Wert aus der Ausgangsspalte übrig. Diese Werte werden nun addiert.

A

B

C

D

E

F

1

 0 

WENN(A2:A7>2;1;0)

WENN(A2:A7<6;1;0)

WENN(B2:B7="II";1;0)

(C2:C7)*(D2:D7)*(F2:F7)*(A2:A7)

2

 1 

 I 

 0 

 1 

 0 

 0 

3

 2 

 II 

 0 

 1 

 1 

 0 

4

 3 

 II 

 1 

 1 

 1 

 3 

5

 4 

 I 

 1 

 1 

 0 

 0 

6

 5 

 II 

 1 

 1 

 1 

 5 

7

 6 

 II 

 1 

 0 

 1 

 0 

8

SUMME(F2:F7)

 8 

2. Weitere Anwendungsbeispiele zum Thema "Bereich berechnen wenn"

A

B

C

D

E

1

02.05.05

8,00 €

Äpfel

Die Berechnungen für

SUMME
MITTELWERT
MAXIMUM
MINIMUM
ANZAHL

sollen nur für eine Auswahl der Zellen
im Bereich B1:B15 durchgeführt werden.

Für die Auswahl werden
die Spalten A und C herangezogen

2

16.05.05

12,00 €

Pflaumen

3

24.05.05

9,00 €

Birnen

4

06.06.05

9,00 €

Äpfel

5

17.06.05

12,00 €

Äpfel

6

26.06.05

8,00 €

Pflaumen

7

03.07.05

14,00 €

Birnen

8

06.07.05

8,00 €

Birnen

9

14.07.05

7,00 €

Pflaumen

10

25.07.05

10,00 €

Birnen

11

26.07.05

10,00 €

Birnen

12

28.07.05

8,00 €

Äpfel

13

30.07.05

9,00 €

Birnen

Werte sollen errechnet werden für:

14

06.08.05

14,00 €

Birnen

Monat:

7

15

29.08.05

13,00 €

Äpfel

Artikel:

Birnen

16

17

Summe

51,00 €

{=SUMME(((MONAT(A1:A15)=E14)*(C1:C15=E15)*(B1:B15)))}

18

Mittelwert

10,20 €

{=MITTELWERT(WENN((MONAT(A1:A15)=E14)*(C1:C15=E15)=1;B1:B15))}

19

Maximum

14,00 €

{=MAX(WENN((MONAT(A1:A15)=E14)*(C1:C15=E15)=1;B1:B15))}

20

Minimum

8,00 €

{=MIN(WENN((MONAT(A1:A15)=E14)*(C1:C15=E15)=1;B1:B15))}

21

Anzahl

5,00 €

{=ANZAHL(WENN((MONAT(A1:A15)=E14)*(C1:C15=E15)=1;B1:B15))}


LizenzBedingungen | AnbieterKennzeichnung | DatenschutzErklärung | Stand: 2013-04-28