Archiv des LibreOffice- und OpenOffice.org-Wiki

[ÜberSicht] [TitelIndex] [WortIndex] [SeiteFinden

Editieren

(./) OOo 2.0

{i} Die nachstehenden Beispiele wurden mit OpenOffice.org, Version 2.0 erstellt. Da sich in dieser Version im Bereich Matrixformeln einiges geändert hat, ist es gut möglich, daß nicht alle Beispiele in früheren Versionen nachvollzogen werden können.


Auf den Seiten CalcFunktionenMatrix/RechnenWenn und CalcFunktionenMatrix/GrundRechenarten wurde beschrieben, wie gängige Funktionen dazu benutzt werden können, ganze Zellbereiche mit einer einzigen Formel zu bearbeiten, wobei als Ergebnis entweder wieder ein Zellbereich herauskommen kann oder auch ein Zusammenzug im Sinn von SUMME, MITTELWERT, etc.

Eigentlich werden aber in Calc ganz besondere Funktionen als Matrix-Funktionen bezeichnet, die überhaupt nur im Zusammenhang mit Matrizen oder auch Arrays Sinn machen.


1. SUMMENPRODUKT

Die Funktion SUMMENPRODUKT ist per Definition eine Matrixformel und muss nicht in {} eingefasst sein. Um die Funktionsweise zu verstehen, hier ein Vergleich von SUMME() und SUMMENPRODUKT()

A

B

C

D

 

Bei der Summenbildung für eine einzelne Spalte ist kein Unterschied zu erkennen zwischen SUMME() und SUMMENPRODUKT

Sobald jedoch mit mehr als einer Spalte gearbeitet wird, ist die unterschiedliche Funktionsweise ersichtlich

1

8,00

2

96,00

=SUMME(A1:A9)

2

12,00

3

96,00

=SUMMENPRODUKT(A1:A9)

3

9,00

5

4

12,00

1

127,00

=SUMME(A1:A9;B1:B9)

5

11,00

3

331,00

=SUMMENPRODUKT(A1:A9;B1:B9)

6

14,00

2

7

9,00

6

127,00

=A1+A2+A3+A4+A5+A6+A7+A8+A9+B1+B2+B3+B4+B5+B6+B7+B8+B9

8

8,00

2

331,00

=A1*B1+A2*B2+A3*B3+A4*B4+A5*B5+A6*B6+A7*B7+A8*B8+A9*B9

9

13,00

7

Wir halten fest: SUMMENPRODUKT multipliziert nebeneinander liegende Zellen und summiert das Produkt. Diese Art der Tabellenverarbeitung bedingt, dass die in einer SUMMENPRODUKT-Formel verwendeten Zellbereiche jeweils gleich groß sind. Zum Vergleich: Eine normale Summenformel kann mehrere Zellbereiche beinhalten, die unterschiedlich groß sind:
=SUMME(A1:A9;B1:B3)
Würde man in gleicher Weise Bereiche in einer Summenprodukt-Formel angeben, also:
=SUMMENPRODUKT(A1:A9;B1:B3)
so würde das zur Fehlermeldung #WERT! führen.

1.1. Umsätze auswerten mit SUMMENPRODUKT und mehreren einschränkenden Bedingungen

A

B

C

D

E

1

Datum

Name

PLZ

Betrag

Artikel

2

02.05.05

Kerstin Meier

52550

9,00 €

Äpfel

3

09.05.05

Barbara Müller

60573

8,00 €

Birnen

4

21.05.05

Berta Hermann

52550

14,00 €

Äpfel

5

22.05.05

Heinz Schmidt

95047

8,00 €

Pflaumen

6

01.06.05

Berta Hermann

52550

10,00 €

Birnen

7

06.06.05

Barbara Müller

60573

12,00 €

Pflaumen

8

07.06.05

Viktor Keller

60573

14,00 €

Birnen

9

13.06.05

Kerstin Meier

52550

7,00 €

Pflaumen

10

14.06.05

Heinz Schmidt

95047

12,00 €

Äpfel

11

24.06.05

Kerstin Meier

52550

11,00 €

Pflaumen

12

24.06.05

Berta Hermann

52550

14,00 €

Pflaumen

13

04.07.05

Daniel Huber

95047

8,00 €

Äpfel

14

06.07.05

Daniel Huber

95047

12,00 €

Äpfel

15

16.07.05

Daniel Huber

95047

9,00 €

Birnen

16

18.07.05

Viktor Keller

60573

9,00 €

Äpfel

17

19.07.05

Viktor Keller

60573

13,00 €

Pflaumen

18

24.07.05

Heinz Schmidt

95047

8,00 €

Pflaumen

19

27.07.05

Barbara Müller

60573

9,00 €

Birnen

20

21

Auswahlkriterien

22

Monat:

5

23

PLZ-Bereich:

50000

59999

24

Artikel:

Äpfel

25

26

Umsatz:

23,00 €

27

Formel:

=SUMMENPRODUKT(D2:D19;MONAT(A2:A19)=B22;(C2:C19>=B23)*(C2:C19<=C23);E2:E19=B24)

28

Da die einzelnen Matrizen in den Parametern der Funktion per Definition mulitpliziert werden, ist auch diese Schreibweise möglich:

29

Formel:

=SUMMENPRODUKT((D2:D19)*(MONAT(A2:A19)=B22)*((C2:C19>=B23)*(C2:C19<=C23))*(E2:E19=B24))

1.2. Erweiterung des Beispiels um ODER-Bedingungen

Da SUMMENPRODUKT für jede Bedingung einen Wahrheitswert generiert und damit multipliziert, bedeutet jede nicht zutreffende Bedingung eine Multiplikation mit 0, was die Auswahl verringert.

Bei ODER-Verknüpfungen geht es jedoch darum, die Auswahl zu erweitern. Das bewerkstelligt man dadurch, dass man die Bedingungen nicht multipliziert, sondern addiert.

A

B

C

D

E

1

Datum

Name

PLZ

Betrag

Artikel

2

02.05.05

Kerstin Meier

52550

9,00 €

Äpfel

3

09.05.05

Barbara Müller

60573

8,00 €

Birnen

4

21.05.05

Berta Hermann

52550

14,00 €

Äpfel

5

22.05.05

Heinz Schmidt

95047

8,00 €

Pflaumen

6

01.06.05

Berta Hermann

52550

10,00 €

Birnen

7

06.06.05

Barbara Müller

60573

12,00 €

Pflaumen

8

07.06.05

Viktor Keller

60573

14,00 €

Birnen

9

13.06.05

Kerstin Meier

52550

7,00 €

Pflaumen

10

14.06.05

Heinz Schmidt

95047

12,00 €

Äpfel

11

24.06.05

Kerstin Meier

52550

11,00 €

Pflaumen

12

24.06.05

Berta Hermann

52550

14,00 €

Pflaumen

13

04.07.05

Daniel Huber

95047

8,00 €

Äpfel

14

06.07.05

Daniel Huber

95047

12,00 €

Äpfel

15

16.07.05

Daniel Huber

95047

9,00 €

Birnen

16

18.07.05

Viktor Keller

60573

9,00 €

Äpfel

17

19.07.05

Viktor Keller

60573

13,00 €

Pflaumen

18

24.07.05

Heinz Schmidt

95047

8,00 €

Pflaumen

19

27.07.05

Barbara Müller

60573

9,00 €

Birnen

20

21

Auswahlkriterien

22

Monat:

5

23

Artikel:

Äpfel

Birnen

Pflaumen

24

25

Umsatz:

39,00 €

27

Formel:

((D2:D19)*(MONAT(A2:A19)=B22)*(E2:E19=B23)) +((D2:D19)*(MONAT(A2:A19)=B22)*(E2:E19=C23)) +((D2:D19)*(MONAT(A2:A19)=B22)*(E2:E19=D23))


LizenzBedingungen | AnbieterKennzeichnung | DatenschutzErklärung | Stand: 2013-04-28