Archiv des LibreOffice- und OpenOffice.org-Wiki

[ÜberSicht] [TitelIndex] [WortIndex] [SeiteFinden

1. Bestimmte Wörter/Zeichen zählen

Wir haben hier eine ähnliche Situation wie beim Ermitteln der Gesamtzahl von Wörtern in einer Zelle:

Man muss nur die Gesamtlänge des Textes vergleichen mit der Länge des Textes nachdem man alle Vorkommen des Suchwortes entfernt hat. Die Differenz dieser Werte muss nun noch durch die Länge des Suchwortes geteilt werden.

1.1. Formelaufbau

A

B

1

Text, in dem das Vorkommen eines bestimmten Wortes oder Zeichens geprüft werden soll

Suchwort

2

Heute morgen war es sehr kalt; so kalt, dass die Scheiben zufroren.

kalt

3

Formel in Spalte A

4

4

=LÄNGE(B2)

5

67

=LÄNGE(A2)

6

Heute morgen war es sehr , so , dass die Scheiben zufroren.

=WECHSELN(A2;B2;"")

7

59

=LÄNGE(WECHSELN(A2;B2;""))

8

8

=LÄNGE(A2)-LÄNGE(WECHSELN(A2;B2;"")

9

2

=(LÄNGE(A2)- LÄNGE(WECHSELN(A2;B2;"")/ LÄNGE(B2)

10

Für den Fall, dass kein Suchbegriff eingegeben wurde:

11

2

=WENN(ISTLEER(B2); "Es wurde kein Suchbegriff erfasst"; (LÄNGE(A2)- LÄNGE(WECHSELN(A2;B2;"")))/ LÄNGE(B2))

12

Das Gleiche funktioniert auch mit Zahlen:

13

123413451234

1

14

3

=WENN(ISTLEER(B13); "Es wurde kein Suchbegriff erfasst"; (LÄNGE(A13)- LÄNGE(WECHSELN(A13;B13;"")))/ LÄNGE(B13))

15

Wenn Gross-/Kleinschreibung ignoriert werden soll:

16

2

=WENN(ISTLEER(B2);"Es wurde kein Suchbegriff erfasst";(LÄNGE(A2)- LÄNGE(WECHSELN(GROSS(A2);GROSS(B2);"")))/LÄNGE(B2))

1.2. Die Anzahl der Vorkommen eines bestimmten Wortes/Zeichens in einem Zellbereich

A

B

1

Text, in dem das Vorkommen eines bestimmten Wortes oder Zeichens geprüft werden soll

Suchwort

2

Heute morgen war es sehr kalt; so kalt, dass die Scheiben zufroren.

kalt

3

Gestern war es nicht so kalt.

4

Ich mag kein kaltes Wetter.

5

4

=WENN(ISTLEER(B2); "Es wurde kein Suchbegriff erfasst"; SUMMENPRODUKT((LÄNGE(GROSS(A2:A4))- LÄNGE(WECHSELN(GROSS(A2:A4);GROSS(B2);"")))/ LÄNGE(B2)))

Alternative: Das ganze geht auch einfacher mit ZÄHLENWENN(A2:A4; ".*kalt.*"), falls der Suchbegriff pro Zelle nur einmal gezählt werden soll. Die Funktionen unterstützen auch alle reguläre Ausdrücke.

2. Siehe auch


KategorieCalc KategorieHowto


LizenzBedingungen | AnbieterKennzeichnung | DatenschutzErklärung | Stand: 2013-04-28